HomePhabricator

[dagit] deps upgrade

Authored by alangenfeld on Jul 22 2019, 8:46 PM.

Description

[dagit] deps upgrade

Summary:

  • yarn upgrade-interactive --latest to update all our deps to the latest version
  • move from react-scripts-ts to react-scripts
  • absorb D651 (tslint to eslint)
  • various changes to get stuff working

Note: this diff will not pass CI until it includes all the offline package changes which makes it entirely not reviewable

Test Plan:
yarn lint
yarn ts
yarn jest
existing tests - explore and execute execute error monster, many events, and composition toy pipelines

Reviewers: #ft, bengotow

Reviewed By: bengotow

Differential Revision: https://dagster.phacility.com/D674

Details

Committed
alangenfeldJul 25 2019, 3:51 PM
Reviewer
bengotow
Differential Revision
D674: [dagit] deps upgrade
Parents
R1:17f762c96f5c: Message for PIPELINE_INIT_FAILURE
Branches
Unknown
Tags
Unknown

Very Large Commit

This commit is very large, and affects more than 1000 files. Changes are not shown.