Rename get_or_create_run() => register_managed_run() and other clean up
Follow up to address comments in https://dagster.phacility.com/D2719
From @schrockn "I also think we should do some things to the naming to make this clearer (feel free to do this in follow on)
Make it clear that this is the codepath for creating "MANAGED" runs. register_managed_run maybe?
Eliminate the status argument.
While we're at it, eliminate all default values for the arguments. It is super easy to forget one and they cause more harm than their potential convenience."
Test Plan: No change in functionality (except one change in flyte compiler)
Reviewers: schrockn, jordanbramble
Reviewed By: schrockn
Differential Revision: https://dagster.phacility.com/D2996