- Added some mypy types, including making Partitions generic.
- schedule_partition_range now returns a list of partitions instead of a function that returns a list of partitions.
- PartitionParams -> Partitions. I don't 100% love Partitions as a replacement, but IMO it gets the meaning across better. PartitionParams makes me expect a dumb struct of parameters to some fancy function.
I prefer partition_params to just partitions, but not in a die-on-the-hill fashion
get_partitions() on Partitions feels weird
we could probably do a better job explaining here the invariant below that one of 'partition_fn' or 'partitions' must be supplied
@rexledesma @dgibson I added one more change, which is to rename TimeBasedPartitions to ScheduleTimeBasedPartitions - this will help disambiguate with some of the things I'm adding for the crag partitions revamp. Also added the check you requested @rexledesma. Would PartitionsDefinition be better than Partitions?