will add test
what exactly should i expose here?
this is the user facing API so last chance to get it right
If we're being super-pedantic, I don't think the word "attempt" should be in the name, because it makes the property name longer while potentially introducing extra confusion.
Every time you run the solid (including the first time, which is not a retry) can be considered an "attempt", so if it was just "attempt_number", then I'd expect that to be 1-indexed instead of 0-indexed. On the other hand, a "retry attempt" is not really a thing (you don't attempt to retry, because the retry will happen regardless of if the solid succeeds or fails, you're attempting to run the solid successfully).
I also agree w/ yuhan that "retry" should be in the name, so I think my favorite option is retry_number, although retry_count seems ok to me as well.