Page MenuHomeElementl

[docs] Schedule testing section, put schedule examples under test
ClosedPublic

Authored by cdecarolis on May 24 2021, 5:04 PM.

Details

Summary

Add testing section for schedules, put schedule examples under test.

Test Plan

test docs build

Screen Shot 2021-05-24 at 1.33.47 PM.png (633×1 px, 150 KB)

Diff Detail

Repository
R1 dagster
Branch
schedule_testing_story
Lint
Lint Passed
Unit
No Test Coverage

Event Timeline

Still a lot of work to do here; putting schedule examples under test and screenshot build

cdecarolis retitled this revision from Schedule testing section to [docs] Schedule testing section.May 24 2021, 5:28 PM
cdecarolis retitled this revision from [docs] Schedule testing section to [docs] Schedule testing section, put schedule examples under test.May 24 2021, 5:34 PM
cdecarolis edited the summary of this revision. (Show Details)
cdecarolis edited the test plan for this revision. (Show Details)
cdecarolis edited the test plan for this revision. (Show Details)

Put examples under test, fix errors

docs/content/concepts/partitions-schedules-sensors/schedules.mdx
144

similar comment as D8058 - dont think instance_for_test is a public api

sandyryza added inline comments.
docs/content/concepts/partitions-schedules-sensors/schedules.mdx
145

I know this isn't directly relevant to this diff, but reading this now makes me feel like get_execution_data is a weird name. "execution" and "data" are both extremely general terms, and "execute" normally has a different meaning in Dagster. Also, "get" implies that we're accessing some attribute, rather than triggering some arbitrarily complex computation. Thoughts on renaming this to something like do_tick? @alangenfeld or @dgibson might have opinions.

Also, whatever we name it, it's not included in the apidoc, so would be good to add it.

docs/content/concepts/partitions-schedules-sensors/schedules.mdx
145

that makes a lot of sense to me as well. get_execution_data is confusing at best, misleading at worst, imo, without really telling you what the function is doing.

docs/content/concepts/partitions-schedules-sensors/schedules.mdx
145

Related: ScheduleExecutionContext also feels like a rough name. Execution seems like it doesn't add anything, or fit into our meaning of execution.

docs/content/concepts/partitions-schedules-sensors/schedules.mdx
145

Agree. Maybe ScheduleTickContext or ScheduleContext?

cdecarolis edited the test plan for this revision. (Show Details)

Update with instance-optional changes

This revision is now accepted and ready to land.May 28 2021, 6:46 PM