Add testing section for schedules, put schedule examples under test.
test docs build
I know this isn't directly relevant to this diff, but reading this now makes me feel like get_execution_data is a weird name. "execution" and "data" are both extremely general terms, and "execute" normally has a different meaning in Dagster. Also, "get" implies that we're accessing some attribute, rather than triggering some arbitrarily complex computation. Thoughts on renaming this to something like do_tick? @alangenfeld or @dgibson might have opinions.
Also, whatever we name it, it's not included in the apidoc, so would be good to add it.
that makes a lot of sense to me as well. get_execution_data is confusing at best, misleading at worst, imo, without really telling you what the function is doing.
Related: ScheduleExecutionContext also feels like a rough name. Execution seems like it doesn't add anything, or fit into our meaning of execution.