Adding a shared RunCoordinator test suite in anticipation for a Run Attribution example (using a Run Coordinator).
Details
Details
Diff Detail
Diff Detail
- Repository
- R1 dagster
- Lint
Lint Passed - Unit
No Test Coverage
Event Timeline
python_modules/dagster/dagster_tests/core_tests/run_coordinator_tests/test_default_run_coordinator.py | ||
---|---|---|
8 | Nitpick, but I think RunCoordinatorTests is a clearer class name than TestRunCoordinator. To me, TestRunCoordinator implies that it's a run coordinator meant to be used in tests (similar to FakeRunCoordiantor or MockRunCoordinator) whereas RunCoordinatorTests implies that it's the tests for a run coordinator. | |
python_modules/dagster/dagster_tests/core_tests/run_coordinator_tests/test_queued_run_coordinator.py | ||
68 | If we need to overload the only test in the base class, are we really getting much benefit from the base class? I tend to think tests are a place where explicit can often be better than DRY. https://thoughtbot.com/blog/the-case-for-wet-tests | |
python_modules/dagster/dagster_tests/core_tests/run_coordinator_tests/utils/__init__.py | ||
6 | What was isort doing? I'd prefer to let it do its thing rather than enforcing our own ordering if possible. |