Page MenuHomePhabricator

Cleans env markers for unsupported Python versions.
AbandonedPublic

Authored by bob on Dec 17 2020, 10:13 PM.

Details

Reviewers
sashank
nate
Summary

Remove environment markers from requirement constraints in setup.py install_requires.

Any environment markers for Python <3.6 should be removed and/or simplified.

Test Plan

bk

Diff Detail

Repository
R1 dagster
Branch
bob--clean-py-version-checks-setuppy
Lint
Lint OK
Unit
No Unit Test Coverage

Event Timeline

bob requested review of this revision.Dec 17 2020, 10:34 PM
python_modules/dagit/setup.py
42–43

can rm this comment too

42–43

I think we can drop future now!

python_modules/dagster/setup.py
55–56

can remove future and python 2 comment also here

83

I feel like this could be relaxed to >=0.7.1

prob worth checking for future in other libraries

Looks great to me, I'll let Nate do the final sign off

  • Removes "future" dependency.

these changes are a subset of this commit