Page MenuHomePhabricator

asset-store AssetStoreContext 2/ util func
ClosedPublic

Authored by yuhan on Sat, Nov 14, 1:14 AM.

Diff Detail

Repository
R1 dagster
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Harbormaster returned this revision to the author for changes because remote builds failed.Sat, Nov 14, 1:28 AM
Harbormaster failed remote builds in B21176: Diff 25689!
yuhan requested review of this revision.Sat, Nov 14, 1:43 AM
python_modules/dagster/dagster/core/execution/context/system.py
425

I think it makes sense to be more specific
get_run_scoped_tuple
get_run_scoped_identifier
get_run_scoped_id

or maybe
get_run_scoped_parts
get_run_scoped_path
that returns a list and can be turned in to a tuple at callsite

431–442

should cover this in the doc block too

python_modules/dagster/dagster/core/execution/context/system.py
425

get_run_step_output_identifier?

fwiw I think we should avoid using the word "path" because it's overloaded elsewhere

python_modules/dagster/dagster/core/execution/context/system.py
425

avoid using the word "path" because it's overloaded elsewhere

good call

throwing more out:

get_run_scoped_output_identifier
get_run_based_output_identifier
get_run_output_identifier

python_modules/dagster/dagster/core/execution/context/system.py
425

renaming it to get_run_scoped_output_identifier and return a list instead

get_keys -> get_run_scoped_output_identifier

This revision is now accepted and ready to land.Wed, Nov 18, 12:47 AM
This revision was automatically updated to reflect the committed changes.