I forget if it was this part or a different one - but I think the last rename we did ended up causing breakages for people who were not version synced across their whole deployment. We don't claim version flexibility - but it sucks to cause breakages for not-yet-used features.
Not sure if its better to =None the param and make it an opt_list since that can basically hide information loss in desynced versions, but figured I would call it out
ya its not clear since this is just us trying to be generously flexible and not break without a good reason.
I think one approach is to try to be flexible until this Job stuff is more ready to go end to end, then make it hard required