Break sub pipelines out into their own class and rename to reflect new semantics
I think I prefer
I guess i dont like that the name is so different but the classes are basically the same
why not just fail 100% of the time here with "SubsetPipelineDefinitions can not be subset again"?
i think inheritance is a good intermediate step (and an incremental improvement) but i don't think it is the long term terminal state. This is especially true in a world post Alex's ExecutablePipeline refactor.
oh i would definitely prefer a hard failure. I assumed that wasn't being done because it was too hard/too much of a pain for now
great step forward
minor nit: generally like to avoid reassigning variables (e.g. pretend that it is const in js)
len check unnecessary
yah i didn't write this, it was introduced in https://dagster.phacility.com/D2794
it's a question whether you think .subset_for_execution['solid_a', 'solid_a'] should magically be the same as .subset_for_execution['solid_a'], i think it would be better to throw