Page MenuHomePhabricator

[2220-2] rename *runtime_type* to *dagster_type* in Pipeline and Solid and relevant variables
ClosedPublic

Authored by yuhan on Wed, Mar 4, 12:14 AM.

Details

Summary

Depends on D2184.

https://github.com/dagster-io/dagster/issues/2220

grep .runtime_type:
https://dagster.phacility.com/P35

the rest are in step_out, step_in (StepInputData and StepOutputData in core.execution.*), and dagster-graphql.schema. should we include those in this?

Test Plan

buildkite

Diff Detail

Repository
R1 dagster
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

yuhan created this revision.Wed, Mar 4, 12:14 AM
yuhan retitled this revision from rename *runtime_type* to *dagster_type* in Pipeline and Solid and rename variables in definitions to rename *runtime_type* to *dagster_type* in Pipeline and Solid and relavent variables in definitions.Wed, Mar 4, 12:20 AM
yuhan edited the summary of this revision. (Show Details)
yuhan added reviewers: prha, schrockn.
yuhan retitled this revision from rename *runtime_type* to *dagster_type* in Pipeline and Solid and relavent variables in definitions to [2/2] rename *runtime_type* to *dagster_type* in Pipeline and Solid and relavent variables in definitions.Wed, Mar 4, 12:22 AM
yuhan retitled this revision from [2/2] rename *runtime_type* to *dagster_type* in Pipeline and Solid and relavent variables in definitions to [2220-2] rename *runtime_type* to *dagster_type* in Pipeline and Solid and relavent variables in definitions.Wed, Mar 4, 2:25 AM
prha requested changes to this revision.Wed, Mar 4, 3:32 AM

This makes sense to me. But let's also make sure we're also grepping / testing outside of the dagster python module....

For example, I see callsites that we need to change in dagster-graphql.

This revision now requires changes to proceed.Wed, Mar 4, 3:32 AM
prha added a comment.Wed, Mar 4, 3:33 AM

Oh, I see you added it as a child diff... Apologies for missing that!

Can we squash these two into a single diff and just amend this one?

yuhan updated this revision to Diff 10244.Wed, Mar 4, 7:22 AM

squash

yuhan retitled this revision from [2220-2] rename *runtime_type* to *dagster_type* in Pipeline and Solid and relavent variables in definitions to [2220-2] rename *runtime_type* to *dagster_type* in Pipeline and Solid and relevant variables.Wed, Mar 4, 7:25 AM
yuhan edited the summary of this revision. (Show Details)
yuhan added inline comments.Wed, Mar 4, 5:54 PM
python_modules/dagster/dagster/utils/backcompat.py
69–80

wonder if we wanna use DeprecationWarning instead of the default UserWarning to differentiate? -- I saw it was all UserWarning everywhere else.

prha accepted this revision.Wed, Mar 4, 8:53 PM
This revision is now accepted and ready to land.Wed, Mar 4, 8:53 PM
yuhan edited the summary of this revision. (Show Details)Thu, Mar 5, 5:44 AM