Page MenuHomePhabricator

(python-config-type-instance-19) Rename is_composite to is_dict

Authored by schrockn on Dec 7 2019, 8:33 PM.



This was always kind of confusing. With the addition of
the composite solid it got really confusing. One things to note
is that is_dict returns True for both Dict and PermissiveDict,
which could be misleading?

Depends on D1597

Test Plan


Diff Detail

R1 dagster
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

schrockn created this revision.Dec 7 2019, 8:33 PM
alangenfeld accepted this revision.Dec 10 2019, 1:40 AM

see you soon for shape or struct renames potentially

This revision is now accepted and ready to land.Dec 10 2019, 1:40 AM
This revision was landed with ongoing or failed builds.Dec 10 2019, 2:00 AM
This revision was automatically updated to reflect the committed changes.