Page MenuHomePhabricator

Upgrade black to 19.10b0
ClosedPublic

Authored by max on Mon, Nov 25, 7:05 PM.

Details

Summary

Resolves https://github.com/dagster-io/dagster/issues/1939 and nagging issues with previous versions of black and py2/3 compatible code.

Test Plan

Unit

Diff Detail

Repository
R1 dagster
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

max created this revision.Mon, Nov 25, 7:05 PM
alangenfeld accepted this revision.Mon, Nov 25, 7:27 PM

if CI passes I'm cool with it

python_modules/dagster/dev-requirements.txt
1

should we have a more flexible dep?

This revision is now accepted and ready to land.Mon, Nov 25, 7:27 PM
max added inline comments.Mon, Nov 25, 7:29 PM
python_modules/dagster/dev-requirements.txt
1

No, we should all be on the same version -- black isn't stable yet

max updated this revision to Diff 6867.Mon, Nov 25, 7:31 PM

Fix check cmd

This revision was automatically updated to reflect the committed changes.